My Pentair Legend Platinum Pool Cleaner Has No Traction In The Pool. Do I Need To Replace The Tires?

to answer your question. yes tires. are they worn down?…if not it, this probably isnt your prob. i know that the cold water hardens up the hose. until spring when the water warms up you will continue to have this prob. you can replace the hose and its swivels. but if you think it is the unit, some pool stores will diagnose your unit for free and even give you free labor on repairs. maybe try to rotate the two front tires to the back and visa-versa. this sometimes helps also.

Here’s the owners manual for your cleaner: http://www.pentairpool.com/pdfs/LegendPl… In it there is an FAQ section, from which I copied this:
A. PROBLEMS & SOLUTIONS
Problem: Legend® Platinum doesn’t move or
moves sluggishly or hangs up on steps.
Solution: 1. Be sure filter pump and booster pump
are on and working properly. (You may
need to clean your pool filter system).
2. Check the Wall Fitting screen for debris
and rinse clean.
3. Check wheel RPM (See page 8).
4. Determine if the Back-Up Valve is
cycling. (Hold the valve out of the
water and the jet should come on for
approx. 30 seconds and shut off for
approx. 3 minutes and 30 seconds.)
5. Check all the Hose connections and
Swivels for leaks that can cause loss
of water pressure.
6. Check debris that may be jammed in
the gear teeth on one of the front drive
wheels. Gently rotate the front wheels
backward to dislodge debris.
The site also has links to parts diagrams and other information.

Comments

2 Responses to “My Pentair Legend Platinum Pool Cleaner Has No Traction In The Pool. Do I Need To Replace The Tires?”
  1. The Pool Dude says:

    Here’s the owners manual for your cleaner: http://www.pentairpool.com/pdfs/LegendPl… In it there is an FAQ section, from which I copied this:
    A. PROBLEMS & SOLUTIONS
    Problem: Legend® Platinum doesn’t move or
    moves sluggishly or hangs up on steps.
    Solution: 1. Be sure filter pump and booster pump
    are on and working properly. (You may
    need to clean your pool filter system).
    2. Check the Wall Fitting screen for debris
    and rinse clean.
    3. Check wheel RPM (See page 8).
    4. Determine if the Back-Up Valve is
    cycling. (Hold the valve out of the
    water and the jet should come on for
    approx. 30 seconds and shut off for
    approx. 3 minutes and 30 seconds.)
    5. Check all the Hose connections and
    Swivels for leaks that can cause loss
    of water pressure.
    6. Check debris that may be jammed in
    the gear teeth on one of the front drive
    wheels. Gently rotate the front wheels
    backward to dislodge debris.
    The site also has links to parts diagrams and other information.

  2. Jim S says:

    simple enough the tires dont hold it to the wall…if no suction no traction……check filter and jandy setup….pump basket and so on….simple things first than worry about the cleaner….no disrespect….good luck

Speak Your Mind

Tell us what you're thinking...
and oh, if you want a pic to show with your comment, go get a gravatar!

Powered by Yahoo! Answers